Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
fehler bei ze1.0 installation
#1
moin moin leute


ich habe mal etwas was einigen wohl nicht schmecken wird. seit samstag haben wir aufamici-zauber.com im ze-chat version v10150622b ein riesen problem. nach dem login erscheint sofort die meldung "Warning: mysqli_error() expects exactly 1 parameter, 0 given in /customers/e/8/2/amici-zauber.com/httpd.www/class/session.class.php on line 483 Error: " ja ich habe mich an die anweisung von zion gehalten 

"Öffne mal die Datei. (class/session.class.php)
Ändere Zeile 483
$do_it = mysqli_query($this->db, $query) OR die("Error: <br>".mysqli_error()); 
Gegen das hier:
$do_it = mysqli_query($this->db, $query) OR die("Error: <br>".mysqli_error($this->db)); "
das ergebnis der ausgabe ist dann diese fehlermeldung"Incorrect integer value: '' for column 'sess_last_message_id' at row 1"

egal was ich mache der feler kommt immer wieder. chat und db gelöscht neu aufgespielt und db importiert immer selbes ergebnis. sowohl mit der version von pat on tour als auch der von harmonix und meiner .

die serverdaten vom amici-zauber http://www.amici-zauber.com/ze1.0
Database server
Server: xxxxvia TCP/IP
Software: MariaDB
Software version: 10.3.10-MariaDB-1:10.3.10+maria~bionic - mariadb.org binary distribution
Protocol version: 10
User: xxxx@10.27.32.48
Server charset: UTF-8 Unicode (utf8)
Web server
nginx/1.14.0
Database client version: libmysql - mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $
PHP extension: mysqli
PHP version 7.1 
da geht garnix

die serverdaten von unserem bastelserver http://rw-spremberg.de/amici-zauber.com

Database server
Server: xxxx via TCP/IP
Software: MariaDB
Software version: 10.1.30-MariaDB-1~xenial - mariadb.org binary distribution
Protocol version: 10
User: xxxx@10.27.18.48
Server charset: UTF-8 Unicode (utf8)

Web server
nginx/1.10.3
Database client version: libmysql - mysqlnd 5.0.10 - 20111026 - $Id: c85105d7c6f7d70d609bb4c000257868a40840ab $
PHP extension: mysqli 
PHP version 7.2.12
da läuft alles fehlerfrei

das bedeutet dann wohl dass in nicht allzu ferner zukunft der ze1.0 nimmer gehen wird, wenn die serverbetreiber alle auf neue datenbanksoftware upgraden
schade eigentlich.  mfg rene
Das Problem ist nicht das Problem, das Problem ist der Nutzer, der das Problem verursacht. 
Was lernen wir ? 
Wir entfernen einfach den Nutzer und das Problem ist gelöst !  Tongue
Antworten
  


Gehe zu:


Benutzer, die gerade dieses Thema anschauen:
1 Gast/Gäste